#17 mac os big sierra, error

Open
opened 2 months ago by leonelhs · 2 comments

Just trying to start using make menuconfig. It can't complete build task on mac os.

make[1]: *** [Makefile:99: y.tab.o] Error 1 make[1]: Leaving directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18' make[1]: Entering directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18'

  ***********************************************************
  *                                                         *
  * GNU bash, version 4.4.18(1)-release (x86_64-apple-darwin20.4.0)
  *                                                         *
  ***********************************************************

rm -f y.tab.o gcc -DPROGRAM='"bash"' -DCONF_HOSTTYPE='"x86_64"' -DCONF_OSTYPE='"darwin20.4.0"' -DCONF_MACHTYPE='"x86_64-apple-darwin20.4.0"' -DCONF_VENDOR='"apple"' -DLOCALEDIR='"/Users/leonel/workspaces/embedded/openadk/host_x86_64-apple-darwin20.4.0/share/locale"' -DPACKAGE='"bash"' -DSHELL -DHAVE_CONFIG_H -DMACOSX -I. -I. -I./include -I./lib -g -O2 -Wno-parentheses -Wno-format-security -c y.tab.c /usr/homes/chet/src/bash/src/parse.y:5741:21: error: implicit declaration of function 'count_all_jobs' is invalid in C99 [-Werror,-Wimplicit-function-declaration]

          temp = itos (count_all_jobs ());
                       ^

1 error generated. make[1]: *** [Makefile:99: y.tab.o] Error 1 make[1]: Leaving directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18' done ---> checking if strings is installed.. found ---> checking if perl is installed.. found ---> checking if gzip is installed.. found ---> checking if git is installed.. found ---> checking if pkg-config is installed.. found ---> checking if ncurses is installed.. found ---> checking if compiler is working.. Cannot compile a simple test programme. You must install a host make and C compiler.

---> checking if zlib is installed.. Cannot compile a libz test program. You must install the zlib development package, usually called libz-dev, and the run-time library.

Just trying to start using make menuconfig. It can't complete build task on mac os. make[1]: *** [Makefile:99: y.tab.o] Error 1 make[1]: Leaving directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18' make[1]: Entering directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18' *********************************************************** * * * GNU bash, version 4.4.18(1)-release (x86_64-apple-darwin20.4.0) * * *********************************************************** rm -f y.tab.o gcc -DPROGRAM='"bash"' -DCONF_HOSTTYPE='"x86_64"' -DCONF_OSTYPE='"darwin20.4.0"' -DCONF_MACHTYPE='"x86_64-apple-darwin20.4.0"' -DCONF_VENDOR='"apple"' -DLOCALEDIR='"/Users/leonel/workspaces/embedded/openadk/host_x86_64-apple-darwin20.4.0/share/locale"' -DPACKAGE='"bash"' -DSHELL -DHAVE_CONFIG_H -DMACOSX -I. -I. -I./include -I./lib -g -O2 -Wno-parentheses -Wno-format-security -c y.tab.c /usr/homes/chet/src/bash/src/parse.y:5741:21: error: implicit declaration of function 'count_all_jobs' is invalid in C99 [-Werror,-Wimplicit-function-declaration] temp = itos (count_all_jobs ()); ^ 1 error generated. make[1]: *** [Makefile:99: y.tab.o] Error 1 make[1]: Leaving directory '/Users/leonel/workspaces/embedded/openadk/tmp/bash-4.4.18' done ---> checking if strings is installed.. found ---> checking if perl is installed.. found ---> checking if gzip is installed.. found ---> checking if git is installed.. found ---> checking if pkg-config is installed.. found ---> checking if ncurses is installed.. found ---> checking if compiler is working.. Cannot compile a simple test programme. You must install a host make and C compiler. ---> checking if zlib is installed.. Cannot compile a libz test program. You must install the zlib development package, usually called libz-dev, and the run-time library.
leonelhs commented 2 months ago
Poster

I have updated bash version by brew install bash, now I need to go on this two error:


---> checking if compiler is working.. Cannot compile a simple test programme. You must install a host make and C compiler.

---> checking if zlib is installed.. Cannot compile a libz test program. You must install the zlib development package, usually called libz-dev, and the run-time library.


My host gcc version shows: Apple clang version 12.0.5 (clang-1205.0.22.9) Target: x86_64-apple-darwin20.4.0

Also changing host compiler whit xcode-select, gets same result


*** I have updated bash version by brew install bash, now I need to go on this two error: *** ---> checking if compiler is working.. Cannot compile a simple test programme. You must install a host make and C compiler. ---> checking if zlib is installed.. Cannot compile a libz test program. You must install the zlib development package, usually called libz-dev, and the run-time library. **** My host gcc version shows: Apple clang version 12.0.5 (clang-1205.0.22.9) Target: x86_64-apple-darwin20.4.0 Also changing host compiler whit xcode-select, gets same result ****

Hi,

is a simple hello world in C compilable with clang? It seems there exist a problem here. best regards Waldemar

Hi, is a simple hello world in C compilable with clang? It seems there exist a problem here. best regards Waldemar
Sign in to join this conversation.
No Label
No Milestone
No assignee
2 Participants
Loading...
Cancel
Save
There is no content yet.