control.in 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. #if 0
  2. Macros used:
  3. CROSS - defined if we are building cross compiling packages. This does
  4. not mean that we are cross-building _this_ package.
  5. _HOST_ - suffix for the arch we are compiling
  6. _TARGET_ - suffix for the arch that the package will target
  7. #endif
  8. Source: uclibc
  9. Section: devel
  10. Priority: optional
  11. Maintainer: David Schleef <ds@schleef.org>
  12. Build-Depends: debhelper
  13. Standards-Version: 3.0.1
  14. #ifndef CROSS
  15. Package: libuclibc-dev
  16. Section: devel
  17. Architecture: any
  18. Depends: libuclibc0, ${shlibs:Depends}
  19. Conflicts: libuclibc-dev_HOST_
  20. Description: A small implementation of the C library
  21. uClibc is an implementation of the standard C library that is
  22. much smaller than glibc, which makes it useful for embedded
  23. systems.
  24. Package: libuclibc0
  25. Section: libs
  26. Architecture: any
  27. Depends: ${shlibs:Depends}
  28. Description: A small implementation of the C library
  29. uClibc is an implementation of the standard C library that is
  30. much smaller than glibc, which makes it useful for embedded
  31. systems.
  32. Package: uclibc-gcc
  33. Section: devel
  34. Architecture: any
  35. Depends: c-compiler, binutils, ${shlibs:Depends}
  36. Description: A compiler wrapper for uClibc
  37. This is a small wrapper for gcc, ld, and other toolchain utilities
  38. to do compilation against uClibc instead of the native libc.
  39. This package is used for cross compiling.
  40. #endif
  41. Package: libuclibc-dev_TARGET_
  42. Section: devel
  43. Architecture: all
  44. Depends:
  45. Suggests: uclibc-gcc_TARGET_
  46. Description: A small implementation of the C library
  47. uClibc is an implementation of the standard C library that is
  48. much smaller than glibc, which makes it useful for embedded
  49. systems. This package is used for cross compiling.
  50. #ifdef CROSS
  51. Package: uclibc-gcc_TARGET_
  52. Section: devel
  53. Architecture: any
  54. Depends: c-compiler_TARGET_, binutils, ${shlibs:Depends}
  55. Description: A compiler wrapper for uClibc
  56. This is a small wrapper for gcc, ld, and other toolchain utilities
  57. to do compilation against uClibc instead of the native libc.
  58. This package is used for cross compiling.
  59. #endif