uclibc-dev.postinst 465 B

12345678910111213141516171819202122
  1. #!/bin/sh
  2. set -e
  3. ldconfig
  4. if [ "$1" = "configure" ]; then
  5. if [ -f /usr/lib/libintl.so.1 ] ; then
  6. rm -f /usr/lib/libc.so
  7. cat > /usr/lib/libc.so << EOF
  8. /* GNU ld script
  9. Use the shared library, but some functions are only in
  10. the static library, so try that secondarily. */
  11. OUTPUT_FORMAT(elf32-i386)
  12. GROUP ( /lib/libc.so.0 /usr/lib/libintl.so.1 )
  13. EOF
  14. chown root.root /usr/lib/libc.so
  15. chmod 0644 /usr/lib/libc.so
  16. fi
  17. fi
  18. #DEBHELPER#